Главная страница
Контакты

    Главная страница


Домашнее задание № 23 для 9 класса

Скачать 12.06 Kb.



Скачать 12.06 Kb.
Дата03.05.2017
Размер12.06 Kb.

Домашнее задание № 23 для 9 класса


Домашнее задание №23

Тема: Алгоритмы работы с величинами


1. Постройте трассировочные таблицы для следующих алгоритмов:


1) A: =1

B: =2

A: =A+B

B: =2xA

2) A: =1

B: =2

C: =A

A: =B

B: =C

3) A: =1

B: =2

A: =A+B

B: =A-B

A: =A-B


1)









2)

3)

2. Между командами ввода и вывода впишите в алгоритм несколько команд присваивания, в результате чего должен получиться алгоритм возведения в 4-ю степень введённого числа (дополнительные переменные, кроме A, не использовать):

Ввод A







Вывод A


3. Чему будут равны значения переменных a ,b, c, x после выполнения алгоритма, если при вводе их значения равны a=5 b=10 c=20? Постройте трассировочную таблицу.

алг счет

цел a,b,c,x

нач ввод a,b,c

x:=a+b+c

a:=a*5

b:=a+b

c:=15

b:=b*3

вывод a,b,c,x

кон











4. Запишите алгоритм циклического обмена значениями трёх переменных a,b,c. Схема циклического обмена: a b c

hello_html_4b5a6405.gif

Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=3, b=1, c=2. Выполнить трассировку.



Алгоритм:


















Трассировочная таблица:





  • B: =2xA
  • B: =2
  • A: =B
  • 3) A: =1
  • Вывод